X
Infolinia
Forum

WAŻNE INFORMACJE:
Klauzula informacyjna na temat prywatności
Regulamin forum


Poszukujesz pomocy w konfiguracji urządzeń? Odwiedź i subskrybuj nasz kanał na YouTube
Musisz się zalogować, aby tworzyć posty i tematy.

Utrata odbiorników z pamięci kontrolera

Ze złych informacji jest taka że wczoraj straciłem znowu jeden ze sterowników, więc już problem wrócił.  Pytanie do osób które mają również problem ze znikającymi urządzeniami. Czy korzystacie z konta root czy z innego . Ja wczoraj dodałem dwa urządzenia na koncie bez praw administratora, i przypisałem dwa urządzenia do jakiś tam kategorii po czym gdy przełączyłem się na swoje konto z uprawnieniami administratora  zauważyłem że brakuje czujnika temperatury [ z tym czujnikiem nic nie robiłem]. Ciekawe czy to może mieć jakiś wpływ. Pozdrawiam

Nie mam tego problemu u siebie, ale moim zdaniem to dobry trop. To byłby kolejny problem związany z kwestią uprawnień. Do tej pory te problemy nie występowały dla użytkownika root, ale inni już je mieli.

Spróbuj działać tylko na root i zobacz jaki będzie efekt.

Zamel mógłby się lepiej przyjrzeć kwestii implementacji uprawnień.

W sofcie kontrolera v1.4.0 z 14.05.2019 wprowadzono mechanizm tworzenia kopii plików urządzeń sparowanych z kontrolerem. Ma on rozwiązać problem znikających urządzeń z zasobów kontrolera ( a ściślej mówiąc ma zapobiec jego wystąpieniu ). W systemie exta life każde urządzenie z poziomu kontrolera jest reprezentowane przez odpowiedni plik. Problem znikających urządzeń związany był z faktem, że czasami plik danego urządzenia podczas zapisu ulegał uszkodzeniu lub nie zapisywał się poprawnie i tym samym nie mógł być już poprawnie odczytany. Obecnie tworzone są kopie plików powiązanych z danymi urządzeniami. Kontroler po wykryciu, że dany plik został uszkodzony automatycznie zastępuje go utworzoną wcześniej kopią. Oczywiście nie uchroni to przed sytuacją, gdy z jakiegoś powodu karta SD w kontrolerze ulegnie całkowitemu uszkodzeniu.

Tak jak wspomniałem mechanizm ma zapobiec wystąpieniu problemu - jeżeli któryś z użytkowników już stracił urządzenia z listy  to zaktualizowanie softu w kontrolerze nie spowoduje, że urządzenia powtórnie się pojawią ( zostaną odzyskane ). W takiej sytuacji konieczne jest zresetowanie danego urządzenia do ustawień fabrycznych i próba jego ponownego dodania do systemu - niestety 🙁

Według mnie to nie jest rozwiązanie problemu, a jedynie workaround. Skoro nie udało się ustalić z jakiego powodu pliki ulegały uszkodzeniu, to nie ma gwarancji, że i pliki kopii będą się zapisywały poprawnie. Oczywiście zmniejszy to prawdopodobieństwo, że awaria wystąpi, ale nie niweluje go. Wykluczam przypadek awarii samej karty SD, bo to oczywiście jest poza kontrolą softu.

Druga sprawa - szkoda, że użytkownik nie ma kontroli nad wykonywaniem się kopii zapasowej. Przykładowo gdy trzeba trochę poeksperymentować z systemem to przydałaby się funkcjonalność zrobienia kopii na żądanie i przywrócenia jej. W aplikacji są do tego przyciski, które do tej pory nie dawały żadnego rezultatu. Czy to już działa?

Na koniec jeszcze kwestia implementacji - dobrze, że w ogóle robi się jakaś kopia, ale szkoda, że nie ma funkcji robienia kopii na zewnętrzny nośnik np pendrive USB, który wykorzystujemy do aktualizacji softu. Awarie kart SD zdarzają się stosunkowo rzadko, ale jednak niestety występują. Użytkownicy Raspberry Pi na pewno coś wiedzą na ten temat.

witam

problem aplikacji oraz komunikacji z kontrolerem jest spory.

u mnie np. bardzo często występuje błąd

czujniki temp. się gdzieś zagubiły z odczytem danych i jest ponad 5000 godzin a chwile wczesniej miały 10 minut.

kontroler był wysłany do sprawdzenia podobno wszystko oki reklamacje odrzucono a w kontrolerze zainstalowano najnowszą wersję softu.

inna sprawa wcześniejsza : repeater zniknął ale po przeglądnięciu go przez serwis i ponownym dodaniu do kontrolera już było ok.

w chwili obecnej próbuje przypisać zresetowane z powodu awarii EFC urządzenia (trzeba dostać sie do wszystkich odbiorników, nadajników, i innych) i aplikacja co chwile wykazuje błąd. tak jakby nie bylo komunikacji aplikacji z kontrolerem - jest to nieco irytujące

nawet jak juz uda sie dodać to jest problem z konfiguracją....

może poczekam na coś? jeszcze nie wiem na co 🙂

Dodane pliki:
  • You need to login to have access to uploads.

Witam!!

Od aktualizacji jak na razie nic mi nie znika na stałe ale nadal nie jest dobrze. Już miałem tak że wchodząc do zakładki pokój  były [ROM ] 3 kanały z 4 a po chwili pojawił się 4 kanał. Ale to bzdura gorzej że wczoraj wracam z pracy a tu sauna w domu. Na zewnątrz 30 stopni a ogrzewanie chodzi na maxa sprawdzam funkcję logiczne i okazało się że wynik sceny wyłączającej ogrzewanie sam się zmienił. Funkcja wyłączająca ogrzewanie miała scenę załącz. Pozdrawiam

Poszukujesz pomocy w konfiguracji urządzeń? Odwiedź i subskrybuj nasz kanał na YouTube
Cytat wswsws data 4 czerwca 2019, 20:09
gorzejż wczoraj wracam z pracy a tu sauna w domu. Na zewnątrz 30 stopni a ogrzewanie chodzi na maxa sprawdzam funkcję logiczne i okazało się że wynik sceny wyłączającej ogrzewanie sam się zmienił. Funkcja wyłączająca ogrzewanie miała scenę załącz. Pozdrawiam

Problemy z samoczynnie zmieniającymi się funkcjami logicznymi były zgłaszane przez użytkowników jeszcze na jesieni 2018 na drugim (pierwszym) forum. Widać Zamel jeszcze nie zdołał zdiagnozować przyczyny i załatać błędu. Pewnie jakieś problemy z operacjami na wskaźnikach w sofcie

No I dopadło i mnie. Straciłem sparowane z kontrolerem odbiorniki Exta Free ☹️☹️ Czeka mnie wspinaczka i ponowne parowanie... Trzeba będzie zrobić tą aktualizację do najnowszej wersji... Czy Wamt ta  aktualizacja pomogła??

Czy ta aktualizacja rozwiązała problem hmmm   -NIE  - Częściowo złagodziła.

Teraz dzieje się tak że jak wejdziesz w zakładkę urządzenia to są wszystkie {na razie nie zauważyłem żeby coś mi uciekło} Ale jak wejdę w zakładkę dom i np. kuchnia to czasem są wszystkie urządzenia a w większości jakiegoś nie ma [raz jest raz znika, potrafi się pojawić na liście gdy na nią patrzysz] co ciekawe wydaje mi się że znikają te same urządzenia albo ten sam kanał z 4 kanałowego ROM-a. Wszystkie urządzenia w systemie mają aktualne oprogramowanie. Tu już chyba egzorcysta może pomóc.   Pozdrawiam

Cytat wswsws data 28 czerwca 2019, 17:39

Czy ta aktualizacja rozwiązała problem hmmm   -NIE  - Częściowo złagodziła.

Teraz dzieje się tak że jak wejdziesz w zakładkę urządzenia to są wszystkie {na razie nie zauważyłem żeby coś mi uciekło} Ale jak wejdę w zakładkę dom i np. kuchnia to czasem są wszystkie urządzenia a w większości jakiegoś nie ma [raz jest raz znika, potrafi się pojawić na liście gdy na nią patrzysz] co ciekawe wydaje mi się że znikają te same urządzenia albo ten sam kanał z 4 kanałowego ROM-a. Wszystkie urządzenia w systemie mają aktualne oprogramowanie. Tu już chyba egzorcysta może pomóc.   Pozdrawiam

Można się było tego spodziewać :(( Ehhhh....

Myślałem, że nieużywanie funkcji logicznych i czasowych sprawi, że kontroler będzie działał bezproblemowo i że uniknę wielu problemów (do tej pory się udawało) w tym tego z gubieniem odbiorników, ale jednak się myliłem 🙁 Soft kontrolera coraz mniej stabilny a stare ubiegłoroczne bugi nadal mają się dobrze.

0